Appalling Customer Service From Virgin Media Business

Since our Suberhub was unfortunate enough to receive the new BUS_V2.37.13 firmware around the 21/10/14 our whole experience with Virgin Media Business Broadband has been terrible, totally a joke would sum it up quite well.

Now in all fairness to NTL / Virgin Media Business, the company I work for has been with them since around 2003 / 2004 for business broadband, i’m told the company has never had any major problems in the past. I’ve worked here for over 3 years and the only issue with the internet until recently 30mins of downtime one morning. However earlier this year we upgraded from the legacy 10mbit package to fastest package available to Virgin Media Business Broadband connection available at the time, 50mbit. Part of this upgrade included our old modem been swapped for a Superhub, which is essentially a modem / router combo.

In our setup the Superhub is essentially used as a modem, we have five static IP addresses which are assigned to our own router. The only thing the Superhub is doing is providing the internet connection. Wireless and any additional functionality is disabled on the Superhub.

The Superhub in this configuration has worked great in our office from May 2014 to October 2014, however all that change when Virgin updated our Superhub firmware from BUS_V2.37.06 to BUS_V2.37.13.

Since then our Superhub has not been able to go much more than 12 hours without crashing. Essentially the internet goes down, the Superhub is inaccessible via its web interface and the only thing that will fix the issue is switching the Superhub off and on again. Doing so allows the Superhub to work for another 12 hours before crashing again.

Over the last five weeks I have been trying to get this problem resolved with Virgin Media, which to all intents and purposes has become a total joke now. No communication exists between anyone at Virgin Media and certainly no communication between Virgin Media to myself on how and when this issue is going to be resolved.

I’m writing this blog of my experiences so far, with the hope of someone with some authority at Virgin Media reading this and doing something about it. About the only positive thing I can say about my experience so far is for Business customers Virgin Media appear to have call centres based in the UK and not other countries like for home broadband customers.

First Call to Virgin Media Business Broadband Customer Services – 21/10/14

The first time i called Virgin Media about the issue of our Superhub crashing was around the 21/10/14. During this call some tests were run on our connection which came back fine, I then explained I thought the problem was with the new BUS_V2.37.13 firmware which had been rolled out to our Superhub. I was told other business customers were reporting problems with the new BUS_V2.37.13 firmware and that someone would call within the next day to downgrade our Superhub back to the BUS_V2.37.06 firmware, which had worked perfectly over the last few months. Sure enough I got a call the next day from an engineer who downgraded the Superhub firmware, after that and all was good for the next few weeks. The Superhub never crashed after that. Pretty good customer service I thought.

Second Call to Virgin Media Business Broadband Customer Services – 17/11/14

Around 17/11/14 I called Virgin Media again as our Superhub had been crashing over night again for the last few days. The Superhub had been upgraded to the new BUS_V2.37.13 again. I was told our connection was fine and this would be escalated to second line support so the Superhub could be downgraded again to the previous BUS_V2.37.06 firmware. When I asked if we would automatically be upgraded again to the newer firmware I was told our account could be tagged so we wouldn’t be upgraded to that firmware again until the issue we were having was resolved.

Third Call to Virgin Media Business Broadband Customer Services – 20/11/14

On the 20/11/14 I called Virgin Media again as no one from second line support had returned my previous call from the 17/11. I explained what had happened previously and asked if our Superhubs firmware could be downgraded again. I was told the Superhub could no longer be downgraded as it would automatically be upgraded again during the night, and no way around this existed.

So that totally contradicts what the previous person told me on the 17th… great.

I was informed the Superhub crashing issue was been looked in to as other business customers had been reporting the same issues. I was then told that someone would call me back within 24 hours and advise me what was going to be done to resolve the issue. Friday came and went, no one had called me back again. (21/11/14)

Fourth Call to Virgin Media Business Broadband Customer Services – 24/11/14

On Monday 24/11/14 I called up Virgin Media again and somehow ended up at their main switchboard after been on hold about 15 mins, I was told I would be transferred to customer support. After been on hold for another 30 minutes apparently I had been transferred through to sales, so was then told I would be transferred again…

After finally been on hold for over an hour the person I was speaking to had no idea why no one had yet called me back about this issue. Some tests were once again run on the line, which of course found nothing wrong just like the previous three calls. I was once again told this would be escalated to second line support who would get back to me within 24 hours. Despite explaining this was supposed to happen last week, and never did, he said as first line support he could do nothing more. I got the impression the person on the other end of the phone couldn’t care less either way.

Useless

Photo of my phone after I had been on hold with Virgin Media for over an hour. At the start of this call I entered my reference number when asked for a pin number (this is what I have blurred out) thinking that might get me through to someone a bit quicker. It didn’t.

 

Fifth Call to Virgin Media Business Broadband Customer Services – 26/11/14

Sure enough its now Wendesday (26/11) and no one from Virgin Media has bothered to call me back. Meanwhile our modem has crashed every night meaning our server hasn’t completed its off site backup to Windows Azure in over a week. No one has been able to remote desktop in to the office, or access anything hosted on our Office server.

So I enjoyed another 45 mins on hold to Virgin Media listing to some space age on hold music. When I finally got to speak to someone, he actually agreed the length of our ongoing problem was unacceptable, which on his system showed as been on-going since 20/11/14. He escalated me to second line support with the view of sending an engineer out. This time I was put on hold and not told someone would call me back within 24 hours. Thinking its a firmware problem i couldn’t see how a new modem would be of any benefit, however i wasn’t going to say no now i had actually got somewhere.

Sure enough the result of this called was a very friendly engineer came out and spent about two and a half hours at our office swapping our old Superhub out for a new one. I have nothing against the engineer himself he was probably one of the friendliest people I have met in a long time, however I do question the quality of the training Virgin Media have given employees.

Apparently Virgin have recently given engineers new laptops running Windows 7 and have taken away their old Laptops running Windows XP. The engineer sent out to us had clearly not been trained on how to use this new laptop, which he indirectly said so himself. I ended up having to show him how to set a static ip address on a network connection on Windows 7, I felt a bit awkward doing that as I didn’t want to tell him how to do his job, then again I also felt bad watching him struggle to find where to do this on Windows 7.

After he had been here for well over an hour the engineer called his college who still had an old Laptop running Windows XP, when he arrived I just left them both to it not wanting to get in the way. After around two and a half hours our new Superhub was up and running with our static ip subnet configured.

On Thursday (27/11) the modem was fine all day, however looking on the modems web interface the next morning I could see it had been restarted during the night, which is probably the reason it hadn’t crashed the next morning.

Sixth Call to Virgin Media Business Broadband Customer Services – 28/11/14

Come Friday (28/11) the Superhub had once again crashed, exactly the same as the Superhub that just got replaced. Our server had not completed its backup to Windows Azure which is scheduled to take place at midnight, so the modem must have crashed sometime before then.

I called Virgin Media again and actually got through to someone in under 10 minutes for once which was nice. I quoted my previous reference number which he sad had been closed on Wednesday as an engineer was sent out… great so now were back to square one. I told him that was unacceptable given how long this has now been ongoing for, however as first line support all he could do was run some tests on the line, which obviously came back ok and open up a new support ticket for us… maybe closing the old one as resolved looks good for internal statistics at Virgin Media?  He told me someone would call back within 24 hours. I informed him the office was closed on Saturday 29/11 as per the business hours he had for our company on file. He informed all been well someone would call later that day. So I was hoping for a call before 5pm yesterday, as I suspected never happened…

Current State of out Broadband Service – 29/11/14

Sure enough today I have had a call and text message saying our internet connection is down again… luckily we have a sales rep in the showroom who has been able to switch the modem on and off again, restoring the connection.

However I do image by Sunday morning the Superhub will have crashed again, which means our server will not have completed it’s offsite backup to Windows Azure once again (I take manual backups too don’t worry) and no one will be able to remote desktop to their office PC, or access any files hosted on our server until Monday.

Its pretty obvious this is a problem with the firmware on the Superhub, which was basically confirmed the first time I called up five weeks ago… however it appears no one at Virgin Media speaks to each other. Everyone I have spoken to has told me something different, or simply wasted my time and Virgin Media’s time.

From reading websites such as Cable Forum I can see we’re not the only business with this issue, and not the business getting no where with Virgin Media customer support. From my experiences so far I have little faith Virgin Media are actively doing anything to resolve this problem, or are even aware of any issues.

Until Virgin can be bothered to sort this out what am I supposed to do? Get a timer plug and set it to cut the power from the modem every 12 hours for a few minutes so the modem can be reset when no one is there?

24-hour-plug-In-timer-switch

I guess a 24 hour plug in timer switch would be a very dirty fix for Virgin Media’s Superhub…

I guess in an ideal world we would have a leased line, however been a fairly small business a minimum of £500+ a month for one is way more than the business can afford.

Seventh Call to Virgin Media Business Broadband Customer Services – 01/12/14

Sure enough the Superhub crashed again on Saturday night, so the office was left without an internet connection all of Sunday, meaning no one could remote desktop in. So first thing Monday morning I called Virgin Media up again. This time the person i spoke to actually acknowledged an issue on the 50meg Business Broadband Package Existed.

He read me a statement out over the phone from the senior fault engineer basically saying this issue only affects 50meg Business Broadband connections and is been treated with the “highest priority” He want on to say something to the effect of more and more business customers reporting issue, however its a firmware issue that Virgin can’t resolve.

I was then basically told because Virgin Media cant provide me service I would be able to leave my contract early, I explained no real alternative exists (sadly!). I was then told i could either upgrade to the 152meg business service the firmware issue doesn’t exist on the modem used for this connection tier, or simply put up with the modem crashing for every 12 hours for the foreseeable future. The upgrade from 50meg to 152meg would apparently add £3 to our bill, brining it to a total of £60 a month. The person i was speaking to said he would have it put on file that we wouldn’t have to pay the £50 install / upgrade fee. With that in mind I told him I just wanted the problem sorting and to upgrade our connection if that would be the easiest solution.

I was then transferred to someone else and kept on hold for another 10 minutes, only to be told I had been transferred to the wrong department (again!!!) and that i needed to speak to someone in sales. So i was yet put on hold again and thankfully only had to wait a couple of minutes this time.

Here i spoke to a very friendly lass called Bethany, who again had no idea of my previous call with the first person i had spoke to, despite him taking details to put on our file, which she would have access to (so i was told). I basically explained all that had happened and said i wanted to upgrade to the 152meg package. That was all fine, then she told me they would be a £50 installation fee. I told her the first person i spoke to had put this on our file and said we wouldn’t have to pay this due to all the problems with out 50meg service over the last six weeks. She said that she couldnt let the £50 install fee go and i would have to phone customer services back within first month after the 152meg service had been installed to get the £50 refund… great yet one person telling me something and someone else at Virgin Media telling me something else.

Then comes more bad news, i’m told Virgin can not currently offer static IP’s on the 152meg Business Broadband service, despite Virgins Media’s own website stating otherwise. Apparently that is worded very poorly and the static IP only applies to the 50meg tier.

 

virgin-media-business-static-ip

I did read that as getting a static IP on either 152meg or 50meg, however i guess it could also read as 50meg only. Despite that the 152meg page did read something to the effect of static ip address where available (that has now been removed) so i didn’t think that would be a problem given i currently have 5x static IP’s on the 50meg service.

 

As i currently have a block of 5x static IP’s on the 50meg service it’s hard to comprehend something that is been sold as the next tier up actually offers less than the previous tier.

So now i can either:

  1. Leave Virgin Media
  2. Put up with our Superhub crashing every 12 hours
  3. Upgrade to 152meg and loose our static IP address, meaning people will not be able to use Remote Desktop Web Access if the IP address randomly changes.

After some thought i decided to upgrade to 152meg to hopefully get a stable connection, having no static IP address is not ideal, however presuming it works the same as Virgins Home Broadband service the IP address you obtain will never change unless you connect the Superhub to a device with a different mac address. I’ve had the same IP address for years at home with Virgin Media, despite going from a VMNG300 modem to a Superhub.

I guess the worst case scenario is ill have to use use a Dynamic DNS service such as No-IP until Virgin are able to offer static IP’s, or look at getting them from else where.

Current Status – 02/12/14

After agreeing to go with the 152meg service i’ve had to sign a SMB Tenant Wayleave, giving Virgin permission to install and keep telecommunications equipment at the premises… despite Virgin having already equipment here for the last 10 years.

Likewsie despite the business already paying Virgin by Direct Debit, i’ve had to get a new Direct Debit Mandate signed.

Maybe that is normal practice, however the reason I found all this a bit strange is because upgrading from the legacy 10meg business broadband tier to 50meg involved none of that.

Now i’m currently waiting for a site survey. When I asked why this was necessary I was told the cable used for connecting the modem up might suitable for 152meg.

Going from 50meg to 152meg seems to be a lot of extra work, considering going from 10meg to 50meg involved a simple phone call, then confirming I wanted to do that via email. Then finally an engineer coming out a week later with a Superhub to replace the old modem.

However i’m told all should be sorted out within 15 days, so all been well any internet issue should be sorted out by December 16th.

Status Update – 12/12/14

A week ago today 05/12/14 Virgin came to do a site survey, after seeing we were already a Business Broadband customer the engineer said ill go to my van and get you a new modem, I might as well upgrade now you as there’s nothing for me to do here.

He simply switched the old Super Hub for a new Super Hub 2 AC, verified the internet was working and we were getting the full 152meg, which we were, then he left.

All i did after that was put the Superhub 2 in modem mode, then reconfigure our router to obtain and IP address from the SuperHub 2 and then hoped for the best.

I came in to work on Monday morning and the internet connection was fine, the new SuperHub 2 hadn’t crashed, same story all this week.

It’s impossible to see how long the SuperHub 2 has been connected as no statistics like that are available in modem mode, however looking at our router it staates the connection has currently been up for 7 days, 6 hours.

virgin-media-superhub-2-ac-business-connection-time

 

So there we have it, 45 days later the problem was fixed.

The only downside now is we do not have a Static IP address, however our IP address has not changed all week and i’m lead to believe it’s only ever likely to if the Mac address was changed on the router. As Virgin will offer Static IP’s in Q1 next year it’s not too much of an issue at the moment, given its unlikely our IP will change in the mean time. The main thing is we appear to have a reliable internet connection once again!

Matt Hill

Matt Hill is in his mid 20′s and has a passion for technology. Matt studied Computer and Network Administration at University and currently works as an IT Administrator for a company based in his home town.

5 Comments

  1. Huwjr   •  

    I’m in the same situation as you bud, check the post and comments here: http://www.cableforum.co.uk/board/12/33699174-virgin-business-superhub-now-has-modem.html

    We’re a web company so internet to us is our bread and butter, we also use VOIP telephony, so are stuck when our internet goes down.

    I’ve personally spent £20 on the phone to virgin last month, my boss and director has probably spent the same or more, in the end VMB turned round to us and said “we’d happily let you leave your contract” and “we are trying to fix the issue but can’t give you an estimate of when or how”.

    They went from saying that 40 in 4,000 customers had the same issue, and then the next day told us that most of their customer base are seeing the issue..

    • Matt Hill   •     Author

      Since posting this blog I have experienced exactly the same as you this week, i got read a statement about it been a widespread fault for all 50meg business broadband customers.

      Then the first suggestion after that was something to the effect of “we will let you out your contract and you can leave” things must be pretty bad when that’s the first thing suggested… I then had the option of putting up with the current fault with no word on when it might be fixed. Or told i could be upgraded to 152meg which was not affected by this firmware issue, however in doing so I would loose my static ip addresses.

      I fail to understand why Virgin cant just downgrade everyone, fix the bug in the firmware, then roll the update out once everything is confirmed working. To me it seems stupid to keep everyone on this buggy firmware. Downgrading is obviously possible as our modem was downgraded for two weeks and never crashed once during that time, now its apparently not possible any more.

      I’ve updated this blog post today, everything from “Seventh Call to Virgin Media Business Broadband Customer Services – 01/12/14” is new.

  2. Alan Davies   •  

    Same here. We are a school – and reliable internet access is key to what is after all our business. Virgin seem to think its simple just to power cycle the router when it stops – but that fails to take in the fact that it requires a journey back into work at some inconvenient time in the evenings – or weekends (Twice) . We have portals with VLEs (Virtual Learning Environments) and stuff both pupils and staff need to access all the time – quite apart from email and our security cameras. And I’m not sure which is worse – the fact that the router keep going down – or the diabolical service from Virgin. I told them they had a fault with the firmware – but they insisted on sending out an engineer to change the power supply…. and then to swap the router….and all the time I and other schools and businesses were screaming at them that its a firmware fault. 50 minute waits on the phone to speak to someone certainly didn’t impress me. I notice that their web sites says that when you dial for support you will be put straight through. A 50 minute wait is not my idea of straight through. The official “statement” on “The Register” by Virgin’s representative completely fails to understand the chaos and disruption this problem continues to cause. Now added an ADSL line with Static IPs (I think its the delivery of static IP by tunnelling is part of the problem – and the 2500 MTU size – yes 2500 – not the 1500 it displays in its interface – doesn’t help). The roll out of the this firmware seems to be have been completely mishandled. Surely all they need to do is to “rebadge” the earlier firmware with a later version number and roll it out. Perhaps they’ll give me job – they will probably be looking for some new employees at a senior level after this catastrophe. (And if they think they don’t – then that is where the problem lies)

  3. You’ll be glad to know this issue hasn’t been resolved, as I just found out after waiting over a month for an installation to be completed (and really bad customer services while waiting, including mixing up my order 3 times!)
    Their solution: offering to upgrade to 152 non-static (which isn’t any good for me as rely on my email server among other things) or put up with it (!?) with some credit on my account.
    Anyone have any ideas of what else I could try? Presume a firmware upgrade isn’t going to happen at all.
    And for the record, this business of having ‘152 with static ip address in the near future’ that sales told us, is apparently not happening any time soon.

  4. Steve   •  

    I am having a similar issue, they have not offered us the 152mb option yet which would be rejected as its critical that we have a static IP. I have recorded what I have been through which ill paste below, I changed over the link on the Friday:

    Weekend – phone calls from the alarm company to say they have lost internet connection

    Monday – line goes down at 3pm I don’t try to report until 4:45pm as was busy and wasn’t told until late, but hang up due to wait. the site was down for 4 hours

    Tuesday – 8am report the line had gone down and as for someone to have a look.

    Tuesday – call again at 3 pm when the line goes down and for him to get back and have a look. the site was down for 4 hours

    Tuesday – engineer turns up for 5 minutes puts something on the line and disappears.

    Wednesday – engineer calls to say nothing is wrong and to call back if it happens again

    Wednesday – called to chase for update and got told I would be given an ETA (I set up monitoring software)

    Wednesday – call again to ask for an update, someone was not going to turn up until Thursday AM

    Wednesday – call to report site had gone down again the site was down for 4 hours

    Thursday – met engineer at site and the line was live, he said he would look at the cab after finding no fault and get back to me – he didn’t get back to me

    Thursday – call to say site had gone down again after waiting an hour on the phone.

    Thursday – got a text after 6pm to say it was being looked at and will call me Friday morning. the site was down for 5 hours

    Friday – no call am chased PM after site went down again waited for a call back

    Friday – got a call back and was promised regular updates

    Weekend – site goes down twice for a few minutes each time

    Monday – got a text to say it was with managers and would call once a decision was made – again no call

    Monday – another text to say site had been up for 20 hours stable but fault was in the hands of backline analysts.

    Tuesday – another text to say the link had been live for 24 hours and passed to network engineer before closing the call and will get back to me when they have more info.

    Wednesday – got a call to say 3 engineers were still looking at it and narrowing down on the problem and will get back to me with some information when they have some.

    Thursday – site went down at 5:53pm Wednesday so logged it first thing. the site only went don for a few minutes.

    Thursday – pm got a text to say network engineers have found the fault and fixed it.

    Bank holiday Monday – pm site went down on and off for 4 hours no one in the office

    Tuesday – called VM first thing to report site went down.

    This is up to today and I’m waiting for a call back still as to the situation. I understand that they are looking at it but I am getting a different answer from each person I speak to. I’m told by one person that its a fault with the network then they put me through to someone else who tells me that its not possible for it to be an issue with the network. The next thing I know its with the network engineers. I am also having to chase multiple times for any form of update even after I’m promised to be called at certain times or days.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.